EDC17 Immobilizer Service Tool

$2.50 each

Older softwware used to perfom tasks relating to the functionality of the immobilizer in EDC17 ecu's. 

If I remember correctly it needs windows XP or Vista.

I do not remember the source of this file, it is highly recommended to only run it in sandbox/virtual machine. I run this along with a bunch of other older questionable software inside a windows xp virtual machine (vmware workstation). You should do the same.